« サカモト教授bot ポータルページ | トップページ | foo_twitter_post v4.1.1 »

2013年4月16日 (火)

foo_twitter_post v4.1.1

foo_twitter_post v4.1.1をリリースしました。

TwitterのAPIアップデートに伴い、本コンポーネントの旧バージョンは2013年5月7日で使用できなくなります。利用されている方は本バージョンにアップデートしてください。


更新履歴

  • Twitter API v1.1に対応した
  • 最新のSDK(2011-03-11)でリビルドした

ダウンロード

foo_twitter_post.zip


マニュアルは前バージョンのものを参照してください。

|

« サカモト教授bot ポータルページ | トップページ | foo_twitter_post v4.1.1 »

foobar2000」カテゴリの記事

パソコン・インターネット」カテゴリの記事

自作ソフトウェア」カテゴリの記事

コメント

有難く使わせてもらおうと思ったのですが、
殆どpostできない状態となっています…

consoleを見ると401で帰ってきてるようです。
奇跡的に手動では一回だけpostできましたが、
以降は手動・自動を問わずアウトのようです。

今のところ原因がつかめていません…

foo_twitter_post: v4.1.1
OS: Windows7 pro SP1 64bit
fb2k: v1.2.3

投稿: kitiketao | 2013年5月20日 (月) 12:27

こんにちは
今日、3.1.1をfoobar2000内で削除(Remove)し、4.1.1に置き換えたところ、
Failed to load DLL: foo_twitter_post.dll
Reason: 指定されたプロシージャが見つかりません。
が表示されてロードされませんでした。
なにか対処することはありますでしょうか?
foobar2000本体のバージョンは1.2.8です。

投稿: Sasu | 2013年6月15日 (土) 09:23

いつもお世話になってます。
このVerを導入したところ、foobar2000起動時に
"Failed to load DLL: foo_twitter_post.dll
Reason: 指定されたプロシージャが見つかりません。"
と出て、このプラグインが機能しなくなったのですが・・・。

投稿: めぐりむ | 2013年6月16日 (日) 23:07

「指定されたプロシージャ~」に関して調査していますが、手持ちのPCは3台とも(fb2k 1.2.8/foo_twitter_post 4.1.1)正常に動作しており、調査が難航しています。

もしかしたら、マイクロソフトから以下のパッケージをダウンロードしてインストールすると解消するかもしれません。

Visual Studio 2012 更新プログラム 1 の Visual C++ 再頒布可能パッケージ

Windowsの64bit なら vcredist_x64.exe を
Windowsの32bit なら vcredist_x86.exe を
ダウンロードしてインストールしてみて下さい。

投稿: きたへい | 2013年6月23日 (日) 12:45

返信ありがとうございます。
リンク先のパッケージを入れてみましたが(修復インストールになりました)、「指定されたプロシージャ~」が表示されます。(OSはXP SP3ですのでx86を入れました)
念のため、Application Data\foobar2000のフォルダを削除してやってみましたが同じでした。
foo_twitter_post.4.1.1.fb2k-componentにリネーム、Components設定画面にZIPをドロップ、Application Data\foobar2000\user-components\foo_twitter_postフォルダを作ってその中にdllを置く、すべて同じ結果でした。

投稿: Sasu | 2013年6月23日 (日) 16:55

Sasuさん、早速試して頂きありがとうございます。
怪しい個所を修正しリビルドしてみました。
以下のDLLで再度試してみて頂けませんでしょうか?

ダウンロード foo_twitter_post_412beta.zip (44.1K)

度々お手数をおかけします。

投稿: きたへい | 2013年6月23日 (日) 17:52

きたへいさん
素早い対応ありがとうございます。dllのロードはされるようになりました(サイズ的にビルド時のライブラリのバージョン違いでしょうか)。が、
1.postしようとするとfoobar2000本体が落ちます。
その際のcrash reportを
https://docs.google.com/document/d/1mqf6ybOdfpIQ30Ek01oQXOOke6tRf1Blcp04Saqe2RI/edit?usp=sharing
に置きました。
2.Authenticationボタンを押しても認証ダイアログが表示されません。cfgファイルを消して立ち上げなおしても同じです。

投稿: Sasu | 2013年6月23日 (日) 18:48

Sasuさん、ありがとうございます。
どうやら「認証ダイアログ」「コメントを入力して投稿」の"ウィンドウを表示"する部分でエラーで落ちているようです。
少し根が深そうなので、小手先では修正できそうにありません。
申し訳ありませんが、もうしばらくお待ち下さい。

投稿: きたへい | 2013年6月23日 (日) 19:57

ありがとうございます。了解しました。
しばらくしたらcrash reportは削除しておきますのでよろしくお願いします。

投稿: Sasu | 2013年6月23日 (日) 21:32

Sasuさん

修正してみました。
上手くいくか、最初と同じ「指定されたプロシージャ~」と出るかのいずれかだと思いますが、お試し下さい。

ダウンロード foo_twitter_post_413beta.zip (873.8K)

crash report はコピーさせて頂きましたので削除してもらって大丈夫です。ありがとうございます。

投稿: きたへい | 2013年6月23日 (日) 22:00

きたへいさん

早速ありがとうございます。
413betaでは「指定されたプロシージャ~」が出ました。

投稿: Sasu | 2013年6月23日 (日) 22:13

Sasuさん
度々お付き合い頂きありがとうございます。
以下ではどうでしょうか?

ダウンロード foo_twitter_post_413beta2.zip (776.9K)

投稿: きたへい | 2013年6月23日 (日) 22:32

413beta2ではAuthenticationダイアログの表示、コメント入力して投稿ともに動作しました。
何度もありがとうございました。

投稿: Sasu | 2013年6月23日 (日) 22:48

Sasuさん

お付き合い頂きありがとうございました。
こちらを最新版として公開し直しますね。

投稿: きたへい | 2013年6月23日 (日) 23:15

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/56729/57185955

この記事へのトラックバック一覧です: foo_twitter_post v4.1.1:

« サカモト教授bot ポータルページ | トップページ | foo_twitter_post v4.1.1 »